Freifunk

Uni Fi-AP

Sowohl der Ubiquiti UniFi AP AC Lite wie auch Pro sind förderfähig!

Diese Seite bezieht sich auf die Ubiquiti UniFi AP AC-Modelle.

FFMR-Gluon auf UniFi-Firmware installieren

Vorwissen

  • Diese Anleitung setzt voraus,
    • dass bekannt ist, wie elementare Netzwerkeinstellungen am eigenen Computer vorgenommen werden können,
    • dass grundlegend mit der Kommandozeile gearbeitet werden kann und
    • dass ein SSH-Client installiert ist. Dies ist unter GNU/Linux-basierenden Betriebssystemen, z.B. Ubuntu, oder macOS idR der Fall. Unter Windows ist hier PuTTY zu empfehlen.

Vorbereitung, Downloads

  • sysupgrade-Image für den entsprechenden Router downloaden: Firmware-Wizard
  • Alte Original-Firmware herunterladen, wird evtl. benötigt:
    • Links: Lite, Pro, LR
    • Auswahl: FirmwareSEE PAST FIRMWARE → Version 3.7.58

Vorbereitung, Netzwerk

  • Direktes Verbinden des Computers mit dem Router:
    • PoE-Injector mit dem Strom verbinden
    • POE-Port des Injectors und LAN-Port des Routers verbinden
    • LAN-Port des Injectors und LAN-Port des Computers verbinden
  • Netzwerkeinstellungen am Computer für den LAN-Port statisch konfigurieren:
    • IP-Adresse: 192.168.1.23
    • Netzwerkmaske: /24 bzw. Subnetzadresse: 255.255.255.0
  • Nachdem der Router gebootet ist (kann 2, 3 min dauern), ist dieser via 192.168.1.20 anpingbar.

Firmwareinstallation

  • Zuerst prüfen wir, ob ein Firmware-Downgrade notwendig ist.
    • SSH-Login auf dem Router: ssh ubnt@192.168.1.20 mit Passwort ubnt
    • In der Kommandozeile des Routers geben wir nun mtd ein und bestätigen mit Enter.
    • Falls eine Fehlermeldung bzgl. eines unbekannten Kommandos auftritt, so muss zuerst die alte Original-Firmware installiert werden. Dies geschieht via TFPT-Flashing, siehe unten.
    • Anschließend die SSH-Verbindung beenden.
  • Hochladen der Freifunk-Firmware auf den Router:
    scp gluon-ffmr-….bin ubnt@192.168.1.20:/tmp/ mit Passwort ubnt
    Der Dateiname ist hierbei der des heruntergeladenen FF-Images.
  • Erneut SSH-Login auf den Router: ssh ubnt@192.168.1.20 mit Passwort ubnt
    • Zum Flashen nun: mtd -r write /tmp/gluon-ffmr-….bin kernel0,
      wobei abermals der Dateiname angepasst werden muss.
    • Der Router wird anschließend neustarten und die SSH-Verbindung schließen.

Netzwerkkonfiguration, die Zweite

  • Die oben gesetzten Netzwerkeinstellungen müssen nun wieder zurückgesetzt werden.
  • Der Computer soll wieder dynamisch via DHCP IP-Adressen beziehen.

Freifunkknotenkonfiguration

  • Nach gewisser Zeit sollte der noch unkonfigurierte Freifunk-Router dem Computer dynamisch eine IP zuweisen.
  • Danach lässt sich übers Webpanel auf http://192.168.1.1/ der Knoten konfigurieren.

TFTP-Flashing

Dies sollte auch dann noch funktionieren, falls der Router durch eine fehlerhafte Firmware nicht mehr bootet. Außerdem lässt sich so auch die original UniFi-Firmware wieder flashen, ebenfalls in älteren Versionen.

  • Direkt mit dem Router verbinden
  • Netzwerkeinstellungen des eigenen Computers anpassen:
    • Statische IP-Adresse: 192.168.1.23/24, wie oben
  • Reset-Button drücken, während des Einsteckens des PoE-Adapters
    • Gedrückt halten, bis das Licht für mehrere Sekunden blau leuchtet
  • Firmware flashen
    • atftp --trace --option "timeout 1" --option "mode octet" --put --local-file firmware.bin 192.168.1.20
  • Die Lichter am Router sollten nun schneller blinken
  • Warten bis das Licht wieder konstant weiß leuchtet

Persönliche Anpassungen

HAL9k-Modus deaktivieren

Standardmäßig leuchtet der innere Ring des Routers im laufenden Betrieb weiß und fällt in dunklen Räumen durchaus auf. Durch einen weiteren Eintrag in /etc/config/system lässt sich das Licht nach dem Booten automatisch ausschalten. Während des Bootvorgangs blinkt der Router weiterhin.

config 'led'
	option 'sysfs' 'ubnt:white:dome'
	option 'default' 0

Batman-Mesh auf einem VLAN

Da das LITE-Modell nur einen physikalischen Ethernetanschluss besitzt, können mehrere Netze über VLANs geroutet werden. Voraussetzend sollte sein, dass der Switch, an welchen der UniFi angeschlossen ist, VLANs unterstützt bzw. nicht verwirft.

In diesem sehr simplen Setup sind sowohl der UniFi "direkt" wie auch ein Batman-Mesh auf einem VLAN, hier der Spiegelslustturm, mit dem Switch verbunden. Die VLAN-ID des Batman-Meshes ist 9.

Folgendes Interface muss zu der /etc/config/network hinzugefügt werden.

config interface 'mesh_wan9'
        option ifname 'eth0.9'
        option auto '1'
        option transitive '1'
        option fixed_mtu '1'
        option proto 'gluon_mesh'

Freifunk-Client auf einem VLAN

Analog zum vorherigen Abschnitt lässt sich auch ein Freifunk-Client VLAN einrichten, welches z.B. eine NanoStation für das eigene Webpanel nutzt.

Hierfür arbeiten wir auf der Kommandozeile des Routers.

## Wir fügen zu "network.client.ifname" unser WAN-Interface
## mit dem gewünschten VLAN (hier 8) hinzu
# uci get network.client.ifname
bat0 local-port
# uci set network.client.ifname="bat0 local-port eth0.8"
# uci commit network
# /etc/init.d/network restart

Verschlüsseltes Freifunk ausstrahlen

In der /etc/config/wireless kann ein zusätzliches verschlüsseltes WLAN-Netzwerk hinzugefügt werden, welches das Freifunknetz ausstrahlt. Hierbei gilt dies nur für radio0, welches die 5GHz-Antenne ist.

config wifi-iface 'clientenc_radio0'
        option disabled '0'
        option network 'client'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option key 'GANS SICHA'
        option ssid 'FLYFUNK'